1001 A+B Format (20分)

PAT-Advanced Level

Posted by Kenshin on June 24, 2020
本文字符数:英文475字 | 中文1289字

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10^6^≤a,b≤10^6^​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include <iostream>
using namespace std;
void print(int x) {
    if (x / 1000) {
        print(x / 1000);
        printf(",%03d", x % 1000);
    } else
        cout << x % 1000;
}
int main() {
    int a, b, c;
    cin >> a >> b;
    c = a + b;
    if (c < 0) {
        cout << '-';
        c = -c;
    }
    print(c);
    return 0;
}

柳神

递归都可用循环写,可惜我不会

1
2
3
4
5
6
7
8
9
10
11
12
13
14
#include <iostream>
using namespace std;
int main() {
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b);
    int len = s.length();
    for (int i = 0; i < len; i++) {
        cout << s[i];
        if (s[i] == '-') continue;
        if ((i + 1) % 3 == len % 3 && i != len - 1) cout << ",";
    }
    return 0;
}