1022 D进制的A+B (20分)

PAT Based Level

Posted by Kenshin on June 24, 2020
本文字符数:英文417字 | 中文887字

输入两个非负 10 进制整数 A 和 B (≤2^​30^​​ −1),输出 A+B 的 D (1<D≤10)进制数。

输入格式:

输入在一行中依次给出 3 个整数 A、B 和 D。

输出格式:

输出 A+B 的 D 进制数。

输入样例:

123 456 8

输出样例:

1103

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
#include <iostream>
using namespace std;
int main() {
    int a, b, c, d;
    string s;
    cin >> a >> b >> d;
    c = a + b;
    if (c == 0) {
        cout << '0';
        return 0;
    }
    while (c) {
        s.insert(0, to_string(c % d));
        c /= d;
    }
    cout << s;
    return 0;
}

柳神

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
#include <iostream>
using namespace std;
int main() {
    int a, b, d;
    cin >> a >> b >> d;
    int t = a + b;
    if (t == 0) {
        cout << 0;
        return 0;
    }
    int s[100];
    int i = 0;
    while (t != 0) {
        s[i++] = t % d;
        t = t / d;
    }
    for (int j = i - 1; j >= 0; j--)
        cout << s[j];
    return 0;
}